Notiz: vmware-player als Console für vSphere / ESX Gäste nutzen

Wer unter Linux / OSX arbeitet, kennt das Problem, immer Windows für den vShpere Client starten zu müssen, um auf eine Gast Konsole zugreifen zu können. Wer nicht den Gast selbst konfigurieren will, sondern nur die Konsole benötigt, kann auf den Vmware Player zurück greifen. Mit dem Parameter „

vmware-player -h [ip des ESX / Vsphere Host] 

“ öffnet sich ein Fenster, bei dem ich dann den gewünschten Gast auswählen kann.

Windows 7 – Unter Ubuntu 9.10 (Vmware Wks 6.5) unbenutzbar(?!)

Also, am Freitag bekam ich die Windows7 DVD und habe am Abend gleich mal probiert, ob ich es installiert bekomme. Unter Vmware sollte das ja kein Problem sein. CD eingelegt, VMware erkennt ein Vista (einige meinen ja, 7 sei ein Vista mit SP) und wollte nur noch die S/N von mir haben. Leider erwies sich das als nicht so glücklich, denn der Installer brach an die 4 Mal ab. Immer mit anderen Meldungen. Man möge doch die Installation erneut starten …. Vor allem hat es ewig gedauert. Über eine Stunde bis zum 1. Reboot. Die Platte ist richtig heiß gelaufen, sodass sie nach dem 4. Versuch erst einmal den Dienst quittierte. Zwischenzeitlich habe ich beim vierten Versuch einfach mal händisch eine VM erstellt, mit Windows 2008 als Ausgangsbasis und siehe da, nach zwei Stunden sah ich dann mal den Desktop. Nur leider ist die Installation faktisch nicht brauchbar. 1.) ist auch nach der Installation der VMware Tools das System sehr langsam (trotz 2x3Ghz + 2,5GB Ram), zum anderen ist die Maus einfach nicht zu gebrauchen. Der Linksklick zeigt so gut wie keine Wirkung und der Focus ist überall, nur nicht unter dem Zeiger. Ich glaube einfach, VMware Wks 6.5 unter Ubuntu 9.10 ist einfach kaputt. Da hilft auch kein Export der eigenen GTK Bibliotheken, die VMware mitbringt. Das Problem tritt allerdings nur unter Windows auf. XP und 7. Unter SLES10/11/Debian …. etc. habe ich dieses Mausproblem nicht, sodass mir unter Windows nur RDP bleibt.

So ganz nebenbei, habe ich auch gleich mein PC Gehäuse gewechselt. Denn die heißgelaufene Platte lag nur auf einer Schalldämmmatte, da sie viele Vibrationen erzeugt. Jetzt habe ich ein Standard Midi Tower von Chiftec und ein anderes über. Als nächstes werde ich mal kräftig aufräumen und die Platten neu strukturieren und Platz für ein natives Windows7 schaffen. Denn unter VMware ist es echt nicht zu gebrauchen …

Xen 3.x in Vmware Workstation/Server mit Xen Bridge

Manchmal dauert es einfach länger, bis man auf die Lösung kommt. Wer zu Testzwecken sein Xen mit auf Reisen nehmen möchte und dazu Vmware Workstation/Server verwendet, hat sich sicher schon gefragt, warum eine Bridge Konfiguration innerhalb von Vmware einfach nicht funktioniert. Es ist so logisch und die Lösung noch einfacher: Xen versetzt die Netzwerkkarte bekannterweise in den Promiscuous Mode, wenn nun aber Vmware als Benutzer gestartet wird, ist es ihm nicht gestattet das Gerät /dev/vmnet0 (meist die Bridge Netzwerkkarte von Vmware) in den entsprechenden Zustand zu versetzen. Also sollte man einfach eine Gruppe anlegen – z.B. vmware – den od. die entsprechenden User dazu setzen und die Berechtigungen auf 660 und Gruppe Vmware ändern. Nach einem erneuten Einloggen funktioniert dann auch die Xen Bridge innerhalb von Vmware wie gewünscht. Und somit bleibt die Freundin davor verschont, den Windows PC mit Vmware mitten in der Nacht einzuschalten.

Und sobald meine udev Regel funktioniert, liefere ich sie natürlich nach.

Vmware Workstation 6.5 und Ubuntu 8.10 -> Keyboard spirenzien

Wer sich wundert, dass eventuell die Tastatur innerhalb einer VM nicht mehr wie gewohnt arbeitet unter Ubuntu 8.10, der legt sich einfach die ~/.vmware/config mit folgendem Inhalt an:


xkeymap.keycode.108 = 0x138 # Alt_R
xkeymap.keycode.106 = 0x135 # KP_Divide
xkeymap.keycode.104 = 0x11c # KP_Enter
xkeymap.keycode.111 = 0x148 # Up
xkeymap.keycode.116 = 0x150 # Down
xkeymap.keycode.113 = 0x14b # Left
xkeymap.keycode.114 = 0x14d # Right
xkeymap.keycode.105 = 0x11d # Control_R
xkeymap.keycode.118 = 0x152 # Insert
xkeymap.keycode.119 = 0x153 # Delete
xkeymap.keycode.110 = 0x147 # Home
xkeymap.keycode.115 = 0x14f # End
xkeymap.keycode.112 = 0x149 # Prior
xkeymap.keycode.117 = 0x151 # Next
xkeymap.keycode.78 = 0x46 # Scroll_Lock
xkeymap.keycode.127 = 0x100 # Pause
xkeymap.keycode.133 = 0x15b # Meta_L
xkeymap.keycode.134 = 0x15c # Meta_R
xkeymap.keycode.135 = 0x15d # Menu

Das habe ich aus irgendeinem Blog gefischt, da die meisten Tasten nicht mehr in meiner Windows VM funktionierten. Es hängt wohl irgendwie mit dem neuen X Server zusammen.

Nachtrag:

Wen es interessiert: das „Problem“ dürften bald auch einige andere Distributionen haben, denn sie werden ebenfalls auf „Evdev“ umstellen.

Ipod Touch unter Vmware Workstation 6.5 > nur bedingt

ich gebe es zu, ich habe mir entgegen jedweder Vernunft erneut einen Apple Ipod (Touch 16Gig)zugelegt. Beim Saturn wurde das Vorgänger Model in der Krabbelbox verkauft, welche zumeist Ausstellungsstücke sind bzw. waren. Allerdings ist dies schon Modell Nummer Zwei, da Nummer Eins sich weigerte etwas anderes außer den Apfel anzuzeigen. Möglicherweise hatte er einfach nur zu wenig Strom, was auch an dem defekten USB Kabel lag.
Umgetauscht und ein paar Minuten gewartet, hielt ich freudestrahlend meinen »Next Generation« Ipod in der Hand. Nun galt es ihn zu befüllen. Nach ein paar Recherchen gab ich fürs erste auf, ihn mit Amarok zu synchronisieren. Mit JailBreak zu hantieren war mir zu umständlich (fürs Erste!), also musste ITunes her. Da Wine (auch die Crossover Variante) mit Itunes8 nicht kann, blieb nur die Vmware Variante. Darin ließ sich zumindest das alltägliche Geschäft erledigen, also Musik aufspielen etc. pp. Was jedoch nicht klappt, ist das Aufspielen von einer neuen Firmware. Der Ipod wird in den Wartungsmodus versetzt und ab dann gibt es nur noch Fehlermeldungen (1611 und Co lassen grüßen). Auch mit ITunes 7.5> funktionierte es nicht. Scheinbar reicht Vmware Workstation 6.5 nicht alles haargenau zum Ipod durch, sodass das Update fehlschlägt. Schließt man diesen dann wieder nativ an eine Windows Kiste an, so lässt er sich ohne weiteres wiederbeleben.

Also an die Google Jünger: Musik aufspielen: Ja, Firmware Upgrade: Nein

Solaris10 in Vmware – höllisch langsam

Ich habe mir heute mal ein Solaris10 per DVD in Vmware installiert. Soweit hatte ich keine Probleme, mal davon abgesehen, dass DHCP einfach nicht funktionieren wollte. Allerdings ist die Kiste (die virtuelle, versteht sich) wirklich unglaublich langsam und fühlt sich an, wie ein P90, wobei die Reaktionszeiten teils im Minutenbereich liegen. Ein paar Befehle eingetippt (via SSH), dann kann ich schonmal wieder 20-30 Sekunden auf das Ergebnis warten. Ich verwende die Version 1.07 von Vmware. Der Rechner selbst läuft unter XP mit 4GB Ram wobei Solaris 512MB hat. CPU ist eine AMD64 X2. Ich weiß echt nicht, wo ich suchen müsste …

Jemand eine Idee?

Edit:

Nach einem Update auf Vmware Server2 und der Installation der Vmware Tools läuft das Ding nun wie gewünscht 🙂

Vmware Server2 RC1

Durch ein anstehendes Projekt habe ich mir mal Vmware Server in der Verison 2 angeschaut. Release Candidate 1. Um den höheren Speicherbereich jenseits der magischen 4GB Grenze nutzen zu können, wollte ich nicht über die Klimmzüge PAE und Co gehen. Daher musste ein Debian Etch in der X64 Fassung her. Die Installation verlief selbst sowohl mit dem Debian eigenen Kernel (2.6.18.irgendwas), als auch mit einem 2.6.25.9 (nötig wegen bestimmter Hardware) ohne den any-any Patch problemlos möglich.

Vmware Server2 RC1

Der erste Eindruck ist zwiespältig. Vmware setzt hier wohl komplett auf das Webinterface, wohinter ein Tomcat werkelt. Die ersten Sekunden sind auch positiver Natur, doch man sieht der Software ihren Status an. Vor allem für mich, als MAC Hardware (PPC) User und Linux steht man ein wenig hilflos da. Zwar kann man eine VM erzeugen, doch Dank fehlender (gescheiter) Java Untersützung läuft mein Mini auf 100% (besser gesagt, der FF2) und der Server schließt sich dem entweder brüderlich an, od. langweilt sich. Wie gut, dass ich noch den Laptop habe, da konnte ich nach ein paar Neustarts (weil sich irgendwas aufgehangen hat) die ersten zwei Maschinen erzeugen. Zum einen Ubuntu 8.10, als auch ein XP pro (je 32Bit). Später gesellte sich noch ein Win2k3 hinzu (bis zur Eingabe der S/N, mangels eben dieser nicht weiter beachtet). Die SLES9 Installation gestaltet sich schwieriger, da das Java Fenster, welches die Vmware Konsole ist, leider außer einem schwarzen Fenster nichts zeigt. Es soll da noch die Option geben, einen klassischen VNC zu nutzen, aber bisher zeigt sich noch nichts. Auch kann ich nichts über die Performance sagen, das wird später folgen, denke ich.

Also ob sich die RC1 Version schon für den Produktiv Einsatz eignen wird, zeigt sich in den nächsten Tagen und Wochen.